Payment Processing Issue

Incident Report for AudienceView Unlimited

Resolved

This incident has been resolved.
Posted Jun 10, 2022 - 16:09 EDT

Monitoring

Payments are now be processing as expected. We are currently monitoring.
Posted Jun 10, 2022 - 15:47 EDT

Investigating

We are currently investigating issues with payment processing.
Posted Jun 10, 2022 - 14:17 EDT
This incident affected: Payment Processing.