PayPal Platform Outage

Incident Report for AudienceView Unlimited

Resolved

We've had multiple reports from clients that PayPal payment processing has resumed, and PayPal itself has issued the following statement:

Resolved: Impact to Payflow processing and applications
Impacted Products:
Payflow
Impacted APIs:
Payflow APIs
Incident Start Time: Mon, 02 Jun 2025 18:00 GMT
Incident End Time: Mon, 02 Jun 2025 18:33 GMT

Resolved:
The impact to Payflow's Production Environment was mitigated on Mon, 02 Jun 2025 at 18:33 GMT.
Posted Jun 02, 2025 - 15:40 EDT

Update

Some clients have reported that PayPal payments processing have resumed.
Posted Jun 02, 2025 - 15:02 EDT

Update

Awaiting confirmation from PayPal that the issue has been resolved.
Posted Jun 02, 2025 - 14:33 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2025 - 14:32 EDT

Investigating

PayPal is reporting an outage affecting several of their products: https://www.paypal-status.com/product/production. We're monitoring this status page and will update when they report the outage has been resolved.
Posted Jun 02, 2025 - 14:32 EDT
This incident affected: Payment Processing.