Email delivery

Incident Report for AudienceView Unlimited

Resolved

This incident has been resolved.
Posted Aug 30, 2022 - 15:18 EDT

Update

We are continuing to investigate this issue.
Posted Aug 25, 2022 - 12:53 EDT

Investigating

We are currently investigating and issue with emails delivery.
Posted Aug 25, 2022 - 12:52 EDT
This incident affected: Email Processing.