VPN access outage
Incident Report for AudienceView Unlimited
Resolved
This issue has been resolved. If you are still experiencing any issues please contact Support.
Posted Apr 27, 2021 - 10:11 EDT
Investigating
We are investigating an outage impacting some VPNs as a high priority issue.
Posted Apr 27, 2021 - 09:09 EDT
This incident affected: Payment Processing.